Mozenda down due to network failure with vendor

Incident Report for Mozenda

Resolved

The incident has been resolved and the Mozenda platform is fully functional.
Posted Sep 18, 2025 - 16:05 MDT

Update

The root cause has been identified and issue resolved with vendor. Platform is partially available now and being restored.
Posted Sep 18, 2025 - 15:19 MDT

Investigating

We are currently troubleshooting a network failure due to a vendor. Mozenda platform is currently down.
Posted Sep 18, 2025 - 14:24 MDT
This incident affected: Web Console, API, Client Connectivity, Client Updating, Harvesting, Premium Harvesting, Publishing, AWS Publishing, RSS Publishing, Email Notifications, Importing, Exporting, Help Center, Phone System, Caching, Website, and Alpha Web Console.