Changes proved to be effective. Mozenda platform performance is now stabilised.
Posted Aug 02, 2024 - 11:51 MDT
Monitoring
Our team has made some chnages to the Mozenda backend to enhance performance. We are closely monitoring these changes to ensure everything is running smoothly.
Posted Aug 02, 2024 - 08:13 MDT
Investigating
We've recently received reports of performance issues on the Mozenda platform. Our team is currently investigating these concerns to identify the root causes and implement solutions. We are committed to resolving these issues as swiftly as possible and will provide regular updates on our progress.