Downtime for equipment upgrades
Incident Report for Mozenda
Resolved
Upgrade completed without incident.
Posted 3 months ago. Mar 28, 2018 - 23:27 MDT
Identified
We will be upgrading some of our equipment tonight beginning at 11 pm EDT. We anticipate that it will take between 1-2 hours. Thanks for your patience.
Posted 3 months ago. Mar 28, 2018 - 21:15 MDT