Account Login Failures
Incident Report for Mozenda
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 30, 2019 - 13:10 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Apr 30, 2019 - 12:47 MDT
Investigating
We are aware of issues where attempting to login to Mozenda fails on occasion. We are investigating with updates to come.
Posted 3 months ago. Apr 30, 2019 - 12:29 MDT
This incident affected: Web Console.