File Packaging and File Downloading Unavailable
Incident Report for Mozenda
Resolved
This incident has been resolved.
Posted 12 days ago. Jun 07, 2019 - 15:16 MDT
Investigating
You will not be able to download any files or package them. Agents will also not be able to download files.
Posted 12 days ago. Jun 07, 2019 - 14:58 MDT
This incident affected: Publishing and Exporting.