System Downtime - Maintenance
Incident Report for Mozenda
Resolved
Maintenance went as planned and is now finished. All services are online.
Posted 9 months ago. Dec 22, 2018 - 18:11 MST
Investigating
We are currently investigating this issue.
Posted 9 months ago. Dec 22, 2018 - 15:00 MST
This incident affected: Web Console, API, Client Connectivity, Client Updating, Harvesting, Premium Harvesting, Publishing, AWS Publishing, RSS Publishing, Email Notifications, Importing, Exporting, Help Center, Phone System, Caching, and Website.