Systemwide outage
Incident Report for Mozenda
Resolved
All System Services should be fully accessible again. We are still investigating the cause and plan to release more information as it comes available.
Posted over 1 year ago. May 31, 2017 - 18:29 MDT
Identified
We have identified the root cause of the problem and are working on restoring all services.
Posted over 1 year ago. May 31, 2017 - 17:41 MDT
Investigating
We are receiving reports that multiple users are unable to access all Mozenda services excluding the website. We are investigating and will provide an update shortly.
Posted over 1 year ago. May 31, 2017 - 17:38 MDT