Unplanned outage
Incident Report for Mozenda
Resolved
Issue has been resolved.
Posted 10 months ago. Feb 20, 2018 - 05:08 MST
Identified
Started at 04:16 MST. Operations team is working to resolve the issue as quickly as possible.
Posted 10 months ago. Feb 20, 2018 - 04:56 MST