Company website down because upstream provider down
Incident Report for Mozenda
Resolved
This incident has been resolved.
Posted Oct 20, 2015 - 21:47 MDT
Monitoring
Looks like they're back up. We'll keep watching to see if they have problems or if this is over.
Posted Oct 20, 2015 - 21:35 MDT
Update
This URL will get you to the sign in page: https://accounts.mozenda.com/login
Posted Oct 20, 2015 - 21:33 MDT
Identified
The upstream provider for our company website is down. We believe they may be down for 40 minutes for the following reason described here: https://wpenginestatus.com/cloud-server-maintenance-may-cause-brief-downtime-2

We will contact them to figure out a better solution for next time. We apologize for this inconvenience.
Posted Oct 20, 2015 - 21:19 MDT