Partial outage affecting some customers
Incident Report for Mozenda
Resolved
This incident has been resolved.
Posted about 1 year ago. Nov 11, 2017 - 12:42 MST
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 year ago. Nov 11, 2017 - 10:08 MST