Planned emergency maintenance affecting some customers
Incident Report for Mozenda
Resolved
This incident has been resolved.
Posted 7 months ago. Nov 15, 2017 - 10:38 MST
Identified
Affected accounts should be back fully online within an hour
Posted 7 months ago. Nov 15, 2017 - 10:22 MST