Company website down
Incident Report for Mozenda
Resolved
This incident has been resolved.
Posted Dec 27, 2015 - 12:21 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 27, 2015 - 09:15 MST
Identified
The hosting company that hosts our company website is currently experiencing difficulties at one of their data centers, causing websites hosted at that location to go offline. We are one of them. We will keep you updated as we receive updates from them.

If you need to sign in to Mozenda, go to accounts.mozenda.com.

Thank you for your patience.
Posted Dec 27, 2015 - 07:54 MST